Bug in V05022015 cant connect to onprem (online is possible)

Topics: Bug
Feb 5, 2015 at 12:07 PM
Hi Tan,

i installed new ver.

at start i get an error:

Informationen über das Aufrufen von JIT-Debuggen
anstelle dieses Dialogfelds finden Sie am Ende dieser Meldung.

************** Ausnahmetext **************
XrmToolBox.InvalidXrmSdkReferenceException: Assembly 'xxxxxxxxxxxxxxxxxxxxxxxxxxx\Xrm Toolbox\Cinteros.Xrm.FetchXmlBuilder.dll' references 'Microsoft.Xrm.Sdk, Version=6.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' which is incompatible with this version of the XrmToolbox which references 'Microsoft.Xrm.Sdk, Version=7.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'. Please remove the dll from the folder and restart the XrmToolbox!
bei XrmToolBox.PluginManager.AssertAssemblyReferencesCorrectXrmSdkVersion(Assembly assembly, String filePath)
bei XrmToolBox.PluginManager.LoadPlugins()
bei XrmToolBox.MainForm.Form1Load(Object sender, EventArgs e)
bei System.Windows.Forms.Form.OnLoad(EventArgs e)
bei System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
bei System.Windows.Forms.Control.CreateControl()
bei System.Windows.Forms.Control.WmShowWindow(Message& m)
bei System.Windows.Forms.Control.WndProc(Message& m)
bei System.Windows.Forms.Form.WndProc(Message& m)
bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Geladene Assemblys **************
mscorlib
Assembly-Version: 4.0.0.0.
Win32-Version: 4.0.30319.34209 built by: FX452RTMGDR.

CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll.

XrmToolBox
Assembly-Version: 1.2015.2.4.
Win32-Version: 1.2015.2.4.

CodeBase: file:///xxxxxxxxxxxxxxxxxx/crm%20tools/Xrm%20Toolbox/XrmToolBox.exe.

System.Windows.Forms
Assembly-Version: 4.0.0.0.
Win32-Version: 4.0.30319.34209 built by: FX452RTMGDR.

CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll.

System.Drawing
Assembly-Version: 4.0.0.0.
Win32-Version: 4.0.30319.34209 built by: FX452RTMGDR.

CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll.

System
Assembly-Version: 4.0.0.0.
Win32-Version: 4.0.30319.34239 built by: FX452RTMGDR.

CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll.

Microsoft.IdentityModel
Assembly-Version: 3.5.0.0.
Win32-Version: 6.3.9600.16384.

CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Microsoft.IdentityModel/3.5.0.0__31bf3856ad364e35/Microsoft.IdentityModel.dll.

System.Core
Assembly-Version: 4.0.0.0.
Win32-Version: 4.0.30319.34209 built by: FX452RTMGDR.

CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll.

System.Xml
Assembly-Version: 4.0.0.0.
Win32-Version: 4.0.30319.34230 built by: FX452RTMGDR.

CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll.

System.Configuration
Assembly-Version: 4.0.0.0.
Win32-Version: 4.0.30319.34209 built by: FX452RTMGDR.

CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll.

Microsoft.GeneratedCode
Assembly-Version: 1.0.0.0.
Win32-Version: 4.0.30319.34230 built by: FX452RTMGDR.

CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll.

McTools.Xrm.Connection.WinForms
Assembly-Version: 1.0.0.0.
Win32-Version: 1.0.0.0.

CodeBase: file:///xxxxxxxxxxxxxxxxxxxxxxxxx/crm%20tools/Xrm%20Toolbox/McTools.Xrm.Connection.WinForms.DLL.

McTools.Xrm.Connection
Assembly-Version: 1.0.3315.606.
Win32-Version: 1.0.3315.606.

CodeBase: file:///xxxxxxxxxxxxxxxxxxxxxxxxx/crm%20tools/Xrm%20Toolbox/McTools.Xrm.Connection.DLL.

McTools.StopAdvertisement
Assembly-Version: 1.0.0.0.
Win32-Version: 1.0.0.0.

CodeBase: file:///xxxxxxxxxxxxxxxxxxxx/crm%20tools/Xrm%20Toolbox/McTools.StopAdvertisement.DLL.

Microsoft.Xrm.Sdk
Assembly-Version: 7.0.0.0.
Win32-Version: 7.0.0.3523.

CodeBase: file:///xxxxxxxxxxxxxxxxxx/crm%20tools/Xrm%20Toolbox/Microsoft.Xrm.Sdk.DLL.

System.Xml.Linq
Assembly-Version: 4.0.0.0.
Win32-Version: 4.0.30319.33440 built by: FX45W81RTMREL.

CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml.Linq/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.Linq.dll.

Microsoft.GeneratedCode
Assembly-Version: 1.0.0.0.
Win32-Version: 4.0.30319.34230 built by: FX452RTMGDR.

CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll.

Cinteros.Xrm.FetchXmlBuilder
Assembly-Version: 1.2014.11.2.
Win32-Version: 1.2014.11.2.

CodeBase: file://xxxxxxxxxxxxxxxxxxxxxx/crm%20tools/Xrm%20Toolbox/Cinteros.Xrm.FetchXmlBuilder.DLL.

System.Windows.Forms.resources
Assembly-Version: 4.0.0.0.
Win32-Version: 4.0.30319.34209 built by: FX452RTMGDR.

CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms.resources/v4.0_4.0.0.0_de_b77a5c561934e089/System.Windows.Forms.resources.dll.

mscorlib.resources
Assembly-Version: 4.0.0.0.
Win32-Version: 4.0.30319.34209 built by: FX452RTMGDR.

CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/mscorlib.resources/v4.0_4.0.0.0_de_b77a5c561934e089/mscorlib.resources.dll.

************** JIT-Debuggen **************
Um das JIT-Debuggen (Just-In-Time) zu aktivieren, muss in der
Konfigurationsdatei der Anwendung oder des Computers
(machine.config) der jitDebugging-Wert im Abschnitt system.windows.forms festgelegt werden.
Die Anwendung muss mit aktiviertem Debuggen kompiliert werden.

Zum Beispiel:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

Wenn das JIT-Debuggen aktiviert ist, werden alle Ausnahmefehler an den JIT-Debugger gesendet, der auf dem

Computer registriert ist, und nicht in diesem Dialogfeld behandelt.

I click on continue, but
if i try the connect to an onprem-version. next error displayed:

"An error occured when verifying security for the message."

If i install (copy over) the old version v1.2015.1.19) i dont get the start-error,
but still cant connect to onprem with error:

"An error occured when verifying security for the message."

Greets Peb
Coordinator
Feb 5, 2015 at 12:15 PM
Please download the latest version of FetchXmlBuilder. The one you have is still referencing CRM 2013 assemblies
Developer
Feb 5, 2015 at 12:30 PM
Again, the error message isn't pretty, but it is helpful! :)
Coordinator
Feb 5, 2015 at 12:36 PM
Absolutely!
Feb 5, 2015 at 1:48 PM
Oh .. this was easy to fix.
Sorry
thx, greets peb