Compatible with CRM 2015?

Topics: Bug, Connection
Dec 15, 2014 at 1:31 PM
Is the Toolbox compatible with CRM 2015? I'm trying to use it for the first time with a new instance of 2015 On-Premise but it won't connect to the new instance.

"An error occurred while retrieving organizations: The server was unable to process the request due to an internal error. For more information about the error, either turn on IncludeExceptionDetailInFaults...blah blah blah"
Coordinator
Dec 15, 2014 at 1:53 PM
I was able to connect to my own OnPremise deployment of CRM 2015.

Which version do you use?
Dec 15, 2014 at 3:56 PM
1.2014.8.26
Coordinator
Dec 15, 2014 at 4:00 PM
There should be at least 4 new versions since then :)

Download the latest one and tell me if things are working better
Dec 15, 2014 at 4:05 PM
Same issue using 1.2014.12.2
Coordinator
Dec 15, 2014 at 4:08 PM
I can't help you more for now... I know it's working for me so I guess the problem comes from your server

Are you sure there is enough memory available? I know that some errors can occur if less than 5% of memory remains
Marked as answer by tanguy92 on 12/16/2014 at 12:22 AM
Dec 15, 2014 at 4:10 PM
Yes - plenty - 256GB
Coordinator
Dec 15, 2014 at 4:14 PM
Can you take a CrmTrace when you try to connect? There should be more details on this error
Dec 15, 2014 at 7:47 PM
I think my deployment was corrupt so I redeployed and now the tool seems to work fine. Thanks.
Marked as answer by tanguy92 on 12/16/2014 at 12:22 AM